CVE-2026-123158
CVSS 8.1 HIGH: sshd in OpenSSH before 10.6p2 on Linux, when musl libc is used without PAM, lacks a workaround for a password…
Vulnerabilities · 1h ago
OpenSSH released 10.6p2, and Alpine fixed packages for releases back to 3.16, addressing CVE-2026-123158 in specific musl-based configurations. The OpenSSH project says it has seen no attacks.
On affected systems, musl returns an asterisk when a password exceeds its 256-byte limit. OpenSSH can mistake that error for the asterisk stored on accounts that reject password logins. Exploitation requires password authentication to be enabled, OpenSSH to run without Pluggable Authentication Modules (PAM), and a password-disabled account alongside another account with a SHA-256 or SHA-512 password hash. An oversized password can then open the otherwise password-disabled account.
On affected Alpine cloud images, an alpine account with passwordless doas can turn that login into root access. Elsewhere, the impact follows the privileges of exposed key-only or service accounts—not simply whether direct root SSH is blocked.
CVSS 8.1 HIGH: sshd in OpenSSH before 10.6p2 on Linux, when musl libc is used without PAM, lacks a workaround for a password…
8 sources covering this story
Kwetsbaarheid verholpen in OpenSSH door OpenSSH Project
De kwetsbaarheid treft Linux systemen die gebruikmaken van musl libc en waarop PAM niet wordt gebruikt.
OpenSSH auth bypass bug hits Alpine Linux, OperWRT
An OpenSSH authentication bypass bug hits Alpine Linux and OpenWRT, hackers attempt to raise fridge temperatures at French blood banks, a [Read More
OpenSSH flaw lets attackers access password-disabled accounts on some Linux systems
The trivial exploit involves sending an arbitrary extra-long password to an OpenSSH server running on a vulnerable Linux configuration, including the popular Alpine Linux.
Meet *sshole, the vulnerability that lets hackers SSH into Linux devices
Certain configurations of Alpine are affected. Other distros may be as well.
OpenSSH: potenziale bypass dell'autenticazione su sistemi Linux basati su musl libc
Rilevata una vulnerabilità con gravità "critica" in OpenSSH che interessa specifiche configurazioni di sistemi Linux - tra cui Alpine Linux - basati su musl libc, libreria standard del linguaggio C per sistemi Linux, alternativa alla più diffusa glibc (GNU C Library).
Get root on a musl Linux system by slamming it with an overly long password
Decade-old vulnerability in OpenSSH is now fixed, so get a-patchin'
OpenSSH flaw lets attackers log into password-disabled Linux accounts
A newly disclosed OpenSSH vulnerability dubbed
OpenSSH Issues Emergency Fix for Flaw Letting Long Passwords Bypass SSH Auth on Alpine Linux
OpenSSH 10.6p2 fixes a critical password bypass allowing access to key-only accounts on affected Alpine Linux servers using long passwords.
Part of the PlainSec briefing for 2026-11-06